Every IPv4 prefix length with netmask, wildcard and host counts, the reserved address ranges, well-known multicast groups and common IPv6 prefix sizes. Click any value to copy it.
IPv4 prefix lengths
Prefix
Netmask / wildcard
Wildcard
Addresses
Usable hosts
In /24 terms
/0
0.0.0.0255.255.255.255
255.255.255.255
4,294,967,296
4,294,967,294
16,777,216 × /24
/1
128.0.0.0127.255.255.255
127.255.255.255
2,147,483,648
2,147,483,646
8,388,608 × /24
/2
192.0.0.063.255.255.255
63.255.255.255
1,073,741,824
1,073,741,822
4,194,304 × /24
/3
224.0.0.031.255.255.255
31.255.255.255
536,870,912
536,870,910
2,097,152 × /24
/4
240.0.0.015.255.255.255
15.255.255.255
268,435,456
268,435,454
1,048,576 × /24
/5
248.0.0.07.255.255.255
7.255.255.255
134,217,728
134,217,726
524,288 × /24
/6
252.0.0.03.255.255.255
3.255.255.255
67,108,864
67,108,862
262,144 × /24
/7
254.0.0.01.255.255.255
1.255.255.255
33,554,432
33,554,430
131,072 × /24
/8
255.0.0.00.255.255.255
0.255.255.255
16,777,216
16,777,214
65,536 × /24
/9
255.128.0.00.127.255.255
0.127.255.255
8,388,608
8,388,606
32,768 × /24
/10
255.192.0.00.63.255.255
0.63.255.255
4,194,304
4,194,302
16,384 × /24
/11
255.224.0.00.31.255.255
0.31.255.255
2,097,152
2,097,150
8,192 × /24
/12
255.240.0.00.15.255.255
0.15.255.255
1,048,576
1,048,574
4,096 × /24
/13
255.248.0.00.7.255.255
0.7.255.255
524,288
524,286
2,048 × /24
/14
255.252.0.00.3.255.255
0.3.255.255
262,144
262,142
1,024 × /24
/15
255.254.0.00.1.255.255
0.1.255.255
131,072
131,070
512 × /24
/16
255.255.0.00.0.255.255
0.0.255.255
65,536
65,534
256 × /24
/17
255.255.128.00.0.127.255
0.0.127.255
32,768
32,766
128 × /24
/18
255.255.192.00.0.63.255
0.0.63.255
16,384
16,382
64 × /24
/19
255.255.224.00.0.31.255
0.0.31.255
8,192
8,190
32 × /24
/20
255.255.240.00.0.15.255
0.0.15.255
4,096
4,094
16 × /24
/21
255.255.248.00.0.7.255
0.0.7.255
2,048
2,046
8 × /24
/22
255.255.252.00.0.3.255
0.0.3.255
1,024
1,022
4 × /24
/23
255.255.254.00.0.1.255
0.0.1.255
512
510
2 × /24
/24
255.255.255.00.0.0.255
0.0.0.255
256
254
1 per /24
/25
255.255.255.1280.0.0.127
0.0.0.127
128
126
2 per /24
/26
255.255.255.1920.0.0.63
0.0.0.63
64
62
4 per /24
/27
255.255.255.2240.0.0.31
0.0.0.31
32
30
8 per /24
/28
255.255.255.2400.0.0.15
0.0.0.15
16
14
16 per /24
/29
255.255.255.2480.0.0.7
0.0.0.7
8
6
32 per /24
/30
255.255.255.2520.0.0.3
0.0.0.3
4
2
64 per /24
/31
255.255.255.2540.0.0.1
0.0.0.1
2
2 p2p
128 per /24
/32
255.255.255.2550.0.0.0
0.0.0.0
1
1
256 per /24
Usable = addresses − 2 (network and broadcast), except /31 (point-to-point, RFC 3021) and /32 (single host).
Reserved IPv4 ranges
Range
Purpose
Defined in
0.0.0.0/8
"This network" · RFC 791
RFC 791
10.0.0.0/8
Private · RFC 1918
RFC 1918
100.64.0.0/10
Shared address space (CGNAT) · RFC 6598
RFC 6598
127.0.0.0/8
Loopback · RFC 1122
RFC 1122
169.254.0.0/16
Link-local (APIPA) · RFC 3927
RFC 3927
172.16.0.0/12
Private (172.16.0.0 – 172.31.255.255) · RFC 1918
RFC 1918
192.0.0.0/24
IETF protocol assignments · RFC 6890
RFC 6890
192.0.2.0/24
Documentation (TEST-NET-1) · RFC 5737
RFC 5737
192.168.0.0/16
Private · RFC 1918
RFC 1918
198.18.0.0/15
Benchmarking · RFC 2544
RFC 2544
198.51.100.0/24
Documentation (TEST-NET-2) · RFC 5737
RFC 5737
203.0.113.0/24
Documentation (TEST-NET-3) · RFC 5737
RFC 5737
224.0.0.0/4
Multicast · RFC 5771
RFC 5771
240.0.0.0/4
Reserved · RFC 1112
RFC 1112
255.255.255.255/32
Limited broadcast · RFC 919
RFC 919
IPv6 prefix sizes
Prefix
Typical use
Holds
/32
Typical allocation to an ISP / LIR
65,536 × /48
/48
Typical site (business) assignment
65,536 × /64
/56
Typical home / small-site assignment
256 × /64
/64
One LAN segment (SLAAC requires /64)
2⁶⁴ addresses
/127
Point-to-point link (RFC 6164)
2 addresses
/128
Single host / loopback
1 address
Special IPv6 ranges
Range
Purpose
::/128
Unspecified
::1/128
Loopback
::ffff:0:0/96
IPv4-mapped
64:ff9b::/96
NAT64 well-known prefix
2000::/3
Global unicast
2001:db8::/32
Documentation
fc00::/7
Unique local (ULA, use fd00::/8)
fe80::/10
Link-local
ff00::/8
Multicast
Well-known multicast groups
IPv4 / IPv6
Used by
IPv6
224.0.0.1ff02::1
All hosts
ff02::1
224.0.0.2ff02::2
All routers (also HSRPv1, LDP hello)
ff02::2
224.0.0.5ff02::5
OSPF all routers
ff02::5
224.0.0.6ff02::6
OSPF DR / BDR
ff02::6
224.0.0.9ff02::9
RIPv2 (RIPng)
ff02::9
224.0.0.10ff02::a
EIGRP
ff02::a
224.0.0.13ff02::d
PIM
ff02::d
224.0.0.18ff02::12
VRRP
ff02::12
224.0.0.22ff02::16
IGMPv3 reports (MLDv2)
ff02::16
224.0.0.102ff02::66
HSRPv2, GLBP (HSRP for IPv6)
ff02::66
224.0.0.251ff02::fb
mDNS (Bonjour, AirPlay)
ff02::fb
224.0.0.252ff02::1:3
LLMNR
ff02::1:3
224.0.1.1ff0x::101
NTP
ff0x::101
224.0.1.129ff0x::181
PTP (IEEE 1588)
ff0x::181
239.255.255.250ff02::c
SSDP / UPnP
ff02::c
—ff02::1:2
DHCPv6 servers and relays
ff02::1:2
—ff02::1:ff00:0/104
Solicited-node (neighbour discovery)
ff02::1:ff00:0/104
224.0.0.0/24ff02::/16
Local network control: never routed, TTL 1
ff02::/16
232.0.0.0/8ff3x::/32
Source-specific multicast (SSM)
ff3x::/32
239.0.0.0/8ff08::/16
Administratively scoped (private use)
ff08::/16
On the wire an IPv4 group maps to MAC 01:00:5e plus its low 23 bits, so 32 groups share each MAC; an IPv6 group maps to 33:33 plus its low 32 bits. In IPv6, x is the scope: 2 link, 5 site, 8 organisation, e global.